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Conditions of Sale 
The purchaser (hereafter referred to as the Licensee) hereby accepts a non-
exclusive, non-transferable licence to use the software, Civil Designer, 

subject to the following conditions: 

1. The license fee shall be payable in advance and this agreement 

commences on said date of purchase. 

2. A separate license fee is payable for each computer upon which the 
Licensee wishes to have simultaneous use of the software. 

3. It is the Licensee’s responsibility to insure the program for the full 
current replacement value.  In the event of theft or loss of the program, 
security disk or security module, or damage to any of the foregoing, the 

license must be re-purchased in full. 

4. The Licensee undertakes not to copy, except for backup purposes, 
reproduce, translate, adapt, vary or modify the software, nor to 
communicate the software to any third party other than the Licensee’s 

employees, without the Licensor’s prior written consent. 

5. The Licensee agrees that it shall not itself – nor through any subsidiary, 
agent or third party – sell, lease, license, sub-license or otherwise deal in 

the software. 

6. The Licensee acknowledges that any and all of the intellectual property 
rights including trademark, trade name, copyright and all other rights 
used or embodied in or associated with the software remain the sole 

property of the Licensor and its principals. 

7. The Licensee shall not question or dispute the ownership of any such 
rights at any time. 

8. No warranty of any kind is expressed or implied with regard to the use 
or application of the software or its fitness for any particular purpose.  
The verification of all results and output is entirely the responsibility of 
the purchaser. 

9. While every care has been taken in the preparation of the Civil Designer 
program and its manual, Knowledge Base cc, its employees and agents 
shall not be liable for any loss or damage (including in particular, 
consequential losses, loss of profits and penalties) suffered by the 
Licensee arising from any cause whatsoever in connection with the Civil 
Designer program or the use thereof whether such loss or damage 
results from breach of contract (including a fundamental breach), 
negligence or any other cause and whether or not this contract is at any 
time cancelled by the Licensee arising from any cause whatsoever in 
connection with the Civil Designer program or the use thereof, whether 

or not this contract is at any time cancelled. 
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Introduction 

Welcome to Civil Designer, the design system created by civil 
engineers for civil engineers, to save you time, effort and 
money.  Now you can work faster, smarter and accomplish 

more.  

This manual introduces you to Civil Designer and gets you 
up and running without delay.  It shows you how to 
accomplish the most common tasks and provides tips on the 
exciting and innovative new features to be found in Civil 

Designer. 

The easy-to-follow tutorial will help you gain hands-on 
experience with the program, and the Beyond the Basics 

section shows you how to complete advanced tasks. 

Where do I go from here? 

After reading this manual you should know the following:  

• How to get Civil Designer up and running 

• How to use the menus and the on-line help system 

• How to input and edit data files 

• How to start a track simulation 

• How to view and output the results of the simulation 
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Typefaces in this manual 

The different typefaces in this manual are used as follows: 

Monospace This typeface represents text as it appears 

onscreen such as prompts. 

Italics Italics are used for emphasis and to introduce 

new terms. 

[Enter] This indicates a key on your keyboard. 

For example: 

“Press [Enter] to complete the entry.” 

Command This typeface indicates a menu option or a 

command. 

For example: 

“Click on the Open icon to load a drawing.” 

Menu commands appear with the path separated by an 
arrow. The instruction Draw ► Ellipses ► Ellipse refers to the 
path you follow by opening the Draw menu, the Ellipses sub-

menu, and by choosing the Ellipse option. 
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How to get support 

Technical support is available from 08.00 to 17.00 Mondays to 
Fridays excluding public holidays at the Knowledge Base 

Support Centre at 086 

On-line help 

The Civil Designer on-line help system is far easier to use 
and more comprehensive than those typically found in other 

software programs. 

It contains about 10 times as much information as this 
manual and provides complete answers to virtually any 
question you may have about features or how to use Civil 

Designer. 

Access on-line Help from the Help menu option at any time, 
or by pressing F1 during the display of any of the dialogs in 
the program.  The help items can be printed using the File ► 

 Print option of the Help window or the Print button on the 

toolbar. 
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Online documentation 

The User Guide and the Reference Manual are supplied on 
the CD-ROM in Adobe Acrobat PDF format. You have the 
option to install the Acrobat Reader when installing Civil 
Designer. This allows you to browse through the manual, to 
search for specific subjects, and to print out all or any 

selection of pages. 
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Conventions used in this manual 

 

Menus and functions 

All the functions in Civil Designer are described in detail in 

the online Reference Manual. 

Mouse 

In this manual, clicking refers to clicking with your left 
mouse button unless otherwise specified. When a click with 
your right mouse button is required, the terms right click or 
right clicking are used. 

Clicking means to press and release a mouse button quickly. 

Cross references 

When a function is mentioned, it is mentioned together with 
the menu in which it can be found. For example, see Line 
(Chained) in the Reference Manual means that the Line 

(Chained) function is described in the Reference Manual. 

See Accurate Drawing means that you should refer to the 
chapter on Accurate Drawing in your Civil Designer User 

Guide.  

Diagrams 

All diagrams are shown with the cursor in Freehand mode 
except where Civil Designer automatically uses another 
mode. However, other modes may be used (see Snap Modes 

in the Reference Manual). 
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Reference 

The Civil Designer Turn program is an integrated module of 
Civil Designer which simulates low speed turning maneuvers 

of user defined vehicles along a specified tracking path.  

This chapter describes each function in detail. 
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Defining a Tracking Path centre line 

A tracking path is the path that will be used in simulating 
vehicle movement. This path can be defined by drawing lines 
and arcs in CAD. There are however a couple of guidelines to 

be followed in doing this: 

 

• The tracking path must start and end with a straight 
line. 

• For reverse simulation around a curve has to be done, 
a straight line must follow each curve. 

• The path can be drawn in any CAD layer, but it makes 
sense to draw it in a separate layer. 

 
It is a good idea to use the Draw ► Line arc line function in 

CAD for this purpose. 

The tracking path that has been drawn must now be 
coordinated before a simulation can be done.  This is done 

using the Turn ► Define Path menu option. 
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Auto Define 

Select the Turn ► Define Path ► Auto Tracking option from the 
main menu, or Right click on the Define path icon on the 

Turn toolbar. 

Use the Auto Define function if the path has been drawn in 
the same sequence as the desired vehicle movement.  You 
will be prompted to indicate the start of the path and the 

program will automatically track the path and coordinate it. 

Manual Define 

Select the Turn ► Define Path ► Manual Tracking option from 
the main menu, or Left click on the Define path icon on the 
Turn toolbar. 

Use this option if Auto Define did not give the desired result.  
This function will prompt you to indicate each line or arc in 

sequence of vehicle movement. 

Right click to indicate the end of the path. 

As you define the path using either one of these options, the 
elements will be highlighted to enable you to verify the 
result.  The coordination will be done according to the 

Coordination Interval value specified in the Setup dialog. 

Remember that it will be impossible for a driver to exactly 
follow a pre defined tracking path along a real roadway.  
Therefore, the results must be used rather conservatively 
and extra allowance beyond the generated envelopes must 
be made for driver variation according to sound engineering 

discretion. 
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Turn Setup 

Press the Setup icon on the Turn toolbar, or select the Turn 

► Setup option from the main menu to display the Setup 

dialog. 

 

 

 

Active Vehicle 

Specify the Vehicle Group File Name to be used, using the 

File Open dialog when clicking the File […] button. 

When a Vehicle group file is specified an Active vehicle, can 
be selected from the Vehicle combo box. Click on the Add 
Vehicle option to add a new vehicle to the current Vehicle 
Group file. A vehicle can also be deleted from the group file 

by clicking the Delete Vehicle button. 

The Angle (decimal) at which the vehicle and trailers must 
start the simulation can be specified in the Tractor Starting 
Angle, Trailer1 Starting Angle and Trailer2 Starting Angle edit 
boxes. These options only apply when forward vehicle 

movement is simulated. 
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Simulation Settings 

The interval, at which the defined track path must be 
coordinated, can be specified in the Coordination Interval (m) 
edit box. If you make this value small (0.3 to 0.1m) the 
simulation will be accurate but slow. The program will also 

add more line entities to the drawing structure.  

Care must be taken when simulating an articulated vehicle 
movement in the reverse direction, especially if the kingpin 
location is in front of the rear axle, not to make the 
coordination interval to small (at least equal to the distance 
between the rear axle and king-pin). A good average 

Coordination interval is in the vicinity of 0.2 to 1.5 m. 

Use the Simulation Type combo box to specify the type of 

simulation needed. This option can be set to: 

• None 

Nothing will be drawn. 

• Track Path 

The position of the wheels of the vehicle and trailers 

along its path will be drawn. 
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• Swept Path 

The amount of space the vehicle and trailers will take 

up during the movement will be illustrated. 

 

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38 39

40

41

42

43

44

45

46

47

48

49

50

51

52

53

54

55

56

57

58

59

60

61

62

63

64

65

66

67

68

69

70

71

72

73

74

75

76

77

78

79

80

81

82

83

84

85

86

87

88

89

 

 

The Simulation Direction can be set to either Forward, or 
Reverse. This direction refers to the vehicle itself and not the 

direction in which the vehicle travels on the track path. 

If the Draw Vehicles on Control Points checkbox is checked, a 
vehicle diagram will be drawn at the start and end of each 

curve and transition curve. 

If the Enforce Steering Angle limits checkbox is checked, the 
program will stop the simulation and warn the user when the 
maximum steering angles are exceeded. If this option is 
unchecked, simulation will continue regardless of the 

steering angles along the tracking path. 

Select the Show Result dialog after Simulation to display the 

Result dialog after each simulation. 

Envelope Drawing Settings 

The drawing layer, line type and pen colour can be specified 
for each of the simulation types specified in the Simulation 

Type combo box, as well as the Vehicle diagram. 

When the Apply Cargo Point Tracking check box is checked 
the program will track a point specified in the Cargo point 
Tracking dialog along the specified tracking path. This 
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tracking line will be drawn in the specified line type and pen 

colour. 

Select Run Simulation to do point tracking in the forward, or 
reverse direction. Point tracking can be done on its own, or 
in conjunction with either the swept, or track path. Press the 
Designer button to display the Cargo Point Tracking 
Designer dialog box where the position of the cargo point 

relative to the active vehicle can be specified. 

The Vehicle Dimension dialog can be displayed directly from 
this dialog by pressing the Edit Vehicle Dimensions button. 

Creating a new Vehicle File 

A Vehicle file is an ASCII file, which can be edited in any text 
editor.  It can contain a number of user-defined vehicles, 
which will be used when simulating vehicle movement along 
a pre-defined tracking path. These files have a *.vcl file 
extension.  A standard vehicle file containing some TRH 17 

vehicles is supplied with the program. 

To create a new Vehicle file, select the Turn ► Setup from the 
main menu to display the setup dialog.  Click on the File 
button next to the file name edit box to display a Windows 
File Open dialog.  In this dialog you can either select an 
existing file, or specify a new file name, which will be created 

automatically. 

Once the file has been created you will be returned to the 
Setup dialog.  If you created a new file, it will be totally 
empty and there will be no vehicles listed in the Vehicle 

combo box. 
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Add a Vehicle to a Vehicle File 

The Turn vehicle group file (*.VCL) is totally user 
configurable.  You can add, edit or delete vehicles at any 

time. 

Press the Add Vehicle button on the Setup dialog. 

 

 

 

Enter a name for the new vehicle in the Vehicle Name edit 
box. This name (32 characters long) will be listed in the 
Vehicle combo box in the Setup dialog. In the Type of Vehicle 

combo box, specify the type of vehicle that has to be added. 

There are 13 standard vehicle types, which will determine 
the bitmap in the Vehicle Dimensions dialog as well as the 
profile symbol that will be used when running Add Profile. 
This setting will also be used in doing a realistic simulation. 
You may have more than one vehicle in a Vehicle File of the 

same type, as long as they have different Vehicle Names. 

Press OK to enter dimensions for the newly added vehicle 
using the Vehicle Dimension dialog. 
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Running a Simulation 

Select the Turn ► Run Simulation option from the main menu 
or press the Run Simulation icon from the Turn toolbar to 

simulate a vehicle movement. 

The Vehicle movement of the Active Vehicle will be 
simulated along a pre-defined track path in the direction 

specified in the Setup dialog. 

The direction in the Setup dialog can be set to either 
forward, or reverse.  This direction refers to the vehicle itself 
and not the direction in which the vehicle travels on the 

track path.  

While the simulation is taking place the program will 
constantly check whether the vehicle exceeds its maximum 
steering angle as well as the maximum angles between the 

tractor and trailers. 

When these maximum angles are exceeded, the program will 
stop the simulation and prompt a reason why it has stopped.  
This action can however be override by disabling the Enforce 

Steering Angle limits check box in the Setup dialog. 

Forward Movement 

When the vehicle is moving in a forward direction, the center 
point of its front axle will always be on the specified track 
path.  The angle of its front wheels will always be parallel to 

the tangent line on a circle or parallel to a straight line. 

The rear wheels of the vehicle will always follow a straight 
line between its current position and the previous position of 
the front wheels.  The same rule applies when there are 

trailers connected to the vehicle. 

The assumption is made that the vehicle is moving at vary 
low speed (parking speed).  When a vehicle then enters a 
curve, the driver will be able to turn the wheels in the new 
direction within a neglect able short distance therefore no 

transition curves have to be used for forward motion. 
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Reverse Movement 

In the reverse direction the center point of the rear axle of 
the vehicle, or last trailer will follow the track path.  This rear 
axle will always be perpendicular to the tangent line on a 
circle, or straight line.  This also determines the angle at 
which the vehicle is traveling and the angle of the steering 

wheels will then be calculated accordingly.   

When there are trailers connected to the vehicle, it is no 
longer safe to assume that no transition curve is needed 
although the vehicle is moving at vary low speed. The driver 
of the vehicle must maneuver the vehicle in such a way that 

it pushes the trailer into the curve. 

In order to perform such a maneuver, there must be a 
transition period before the trailer enters, or exits the 
circular curve.  This also means that the center of the 
trailer’s rear axle will no longer follow the defined path 

exactly around the circular curve. 

This discrepancy depends on the length of the transition 
curves, which the program will calculate according to the 
maximum steering angle of the vehicle.  This will ensure that 
the transition curves and therefore the discrepancy be kept 

as short as possible. 
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The direction of movement, active vehicle and the 
coordination interval can be changed without re-defining the 
track path.  The program will automatically re-coordinate the 

track path and insert transition curves when needed. 
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Because a driver can successfully negotiate the same turn in 
different ways, additional allowance must be made for driver 
variability, according to sound engineering judgment over 
and above what might have been made during forward 

maneuvers. 

When simulating trailer or semi trailer reverse maneuvers, 
extra clearance of +- ¾ of the vehicle width should be 

applied on each side of the envelope. 

 

Add a Vehicle Profile 

A vehicle profile is a symbol of the active vehicle, similar to 
the drawing in the Vehicle Dimension dialog that can be 

placed onto the main drawing. 

These symbols exist in a symbol drawing which is supplied 
with the program called VehicleSymbols.drg and will be 
stored in the Symbols sub-directory of the installation 

directory.  

Select the Turn ► Add Profile option from the main menu, or 
press the Add Simulation icon on the Turn toolbar to add a 

vehicle profile.   

You will be prompted to indicate the position where you 

want the profile to be placed as well as the desired rotation.     

Delete Simulation 

Select the Turn ► Delete Run option, or press the Delete 
Simulation button on the Turn toolbar to delete the last 
simulation.  The CAD layers for the Track Path, Swept Path 
and Vehicle Drawing as specified in the Setup dialog will be 

deleted. 
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Vehicle Dimension Dialog 

Select the Turn ► Vehicle Dimension option from the main 
menu or press the Vehicle Dimension icon on the Turn 
toolbar to display the vehicle dimensions of the active 

vehicle. 

There are 13 standard vehicle types, which can be used to 
define most standard vehicles. You can have more than one 
vehicle in the group file from the same vehicle type, as long 
as each vehicle name is unique. These vehicle types, dictates 
the format of the Vehicle dimension dialog as well as the 

simulation process. 

All the dimensions on these dialogs as well as the Vehicle 
Name can be edited and will be stored in the Vehicle Group 
File when OK is pressed. When changing the Vehicle name, 
you can either change the name of the current vehicle, or 
create a new vehicle with the changed name.  

The 13 vehicle types can be sub-divided into 5 main groups 
namely, Single Unit Vehicles, Articulated Vehicles, Vehicles 
with full trailers, Vehicles with semi-trailers and Aircraft. 

These vehicle groups will be discussed subsequently.  
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Single Unit Vehicles 

The following vehicles are single unit vehicles: 

• Passenger Car 

• Single Unit Truck 

• Single Unit Bus 

• Forklift 

• Tractor vehicles for the other vehicle groups 

 

Dimension 1 Front Overhang. The distance from the center 
of the front wheel to the front bumper 

Dimension 2 Wheelbase. The distance between the center 
of the front wheels and the center of the rear 
axle group. 

Dimension 3 Rear Overhang. The distance from the center 
of the rear wheel to the rear bumper 

Max. Steer Angle The maximum angle (in degrees) that the 
steering wheels can be turned to either side. 

Track Width The distance from the outer-most point of the 
right wheel to the outer-most point of the left 
wheel. 

Total Width The greatest width of the vehicle’s body. 

The Forklift Vehicle type steers with its rear wheels. 

1 2 3 
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Articulated Vehicles 

The following vehicles are articulated vehicles: 

• Articulated Truck, with or without trailers. 

• Articulated Bus 

 

Dimension 1 The distance rear bumper of the tractor to the 
center point of the kingpin. 

Dimension 2 The distance from the center of the kingpin to 
the front of the trailer. 

Dimension 3 The distance from the center of the kingpin to 
the center of the trailer’s rear axle group. 

Dimension 4 The distance the center of the trailer’s rear 
axle group to the trailer’s rear bumper. 

Max. Tractor/Trailer 
Angle 

The maximum allowable angle (in degrees) 
between the tractor and trailer. 

Track Width The distance from the outer-most point of the 
right wheel to the outer-most point of the left 
wheel. 

Total Width The greatest width of the trailer’s body. 

 

1 

2 

3 

4 
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Vehicles with full trailers 

The following vehicles are vehicles with trailers: 

• Single Unit Truck \ Trailer. 

• Articulated Truck \ Trailer. 

 

Dimension 1 The Distance from the tractor’s tow bar to the 
trailer’s front axle. 

Dimension 2 The distance from the trailer’s front axle to the 
front of the trailer’s body.. 

Dimension 3 The distance between the trailer’s front axle 
and the trailer’s rear axle group. 

Dimension 4 The distance from the trailer’s rear axle group 
to the trailer’s bumper. 

Max. Tractor/Trailer 
Angle 

The maximum allowable angle (in degrees) 
between the tractor and trailer. 

Track Width The distance from the outer-most point of the 
right wheel to the outer-most point of the left 
wheel. 

Total Width The greatest width of the trailer’s body. 

 

2 3 4 

1 
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Vehicles with Semi-Trailers 

The following vehicles are vehicles with semi-trailers: 

• Passenger Car\Semi-Trailer. 

• Single Unit Bus \ Semi-Trailer. 

 

Dimension 1 The Distance from the tractor’s tow bar to the 
front of the trailer’s body. 

Dimension 2 The distance from the front of the trailer’s body 
to the center of the trailer’s axle group. 

Dimension 3 The distance from the trailer’s rear axle group 
to the trailer’s rear bumper. 

Max. Tractor/Trailer 
Angle 

The maximum allowable angle (in degrees) 
between the tractor and trailer. 

Track Width The distance from the outer-most point of the 
right wheel to the outer-most point of the left 
wheel. 

Total Width The greatest width of the trailer’s body. 

 

1 2 3 
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Aircraft 

The following vehicles are aircraft: 

• Aircraft (Nose Steer). 

• Aircraft (Tail Steer). 

Two aircraft vehicle types have been added to the list. The 
first for aircraft with the normal tricycle undercarriage, that 
steers with the nose wheel. The second aircraft type is for 
aircraft where the main landing wheels are situated at the 

front and steers with the tail wheel (i.e. tail draggers).  

 

1 2 3 4 5 

6 7 8 9 

10 11 
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Plan View 

The dimensions at the bottom of the drawing indicate 
positions where the wings and tail are attached to the 

aircraft’s body.  

Dimension 1 Distance from the nose to the base of the 
wing. 

Dimension 2 Width of the wing against the aircraft’s body. 

Dimension 3 Distance between the back of the wing and the 
base of the tail. 

Dimension 4 Width of the tail against the aircraft’s body. 

Dimension 5 Distance from the back of the tail to the tip of 
the tail. 

The sum of these dimensions is equal to the total length of 

the aircraft. 

The dimensions at the top of the drawing specify the 
positions of the wing tips and tail tips relative to the base of 

the wings and tail. 

Dimension 6 The Distance from the base of the wing to the 
front point of the wing tip. 

Dimension 7 The width of the wing at the wing tips. 

Dimension 8 The Distance from the base of the tail to the 
front point of the tail tip. 

Dimension 9 The width of the tail at the tail tips. 

 

Side Elevation 

Dimension 10 Front Overhang: Distance from the nose 
to the center of the front wheel. 

Dimension 11 Wheelbase: Distance between the center of 
the front wheel/s and the center of the rear 
wheel, or main wheel group. 

 

Overall dimensions 

Wing Span The distance from the left wing tip to the right 
wing tip. 

Tail Width The distance from the left tail tip to the right tail 
tip. 

Body Width The width of the widest part of the aircraft‘s 
body. 
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Landing Gear Dimensions 

Rear/Front Track width The distance between the outside edges of the 
main wheels. 

Front wheel diam The diameter of the front wheel/s. 

Rear wheel diam The diameter of the rear wheel/s 

For aircraft with compound main landing wheels, the Front/ 
Rear wheel diameter should be equal to the total length of 

the wheel group.  

Note: If the position of the pilot has to be tracked, use the 
Cargo Point Tracking function. 
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Cargo Point Tracking 

Press the Designer button on the Setup dialog to display the 

Cargo point-tracking dialog. 

 

A plan view of the active vehicle will be drawn on the display 
area when the dialog opens. You can alter the view in the 
display area by magnifying (m key), de-magnifying (d key), 
panning (p key), refreshing (s key) or redrawing (r key). 

The 0,0 coordinate is situated at the center of the vehicle's 
front axle. You can specify the location of the cargo by using 
the radio buttons in the [Cargo Location] group. The active 

part location will be highlighted in a cyan pen. 

The cargo point can be specified by graphically indicating 
the position on the display area, or entering the coordinates 
in the [Point Position] group. You can also snap to the 

nearest point on the drawing by pressing the "J" key. 

A blue circle represents the cargo point that will be tracked 
when running the next simulation. 

Press OK to accept the changes and to return to the Turn 

Setup Dialog. 
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Simulation Results 

Select the Turn ► Display Results option from the main menu, 

or press the Results icon on the Turn toolbar. 

 

 

 

If the Show Result dialog after Simulation option was selected 
in the Turn Setup Dialog, or the Display Results menu item 
was selected and a simulation was done the results dialog 
will be displayed. Select the Don't show this dialog again 
option not to display the dialog automatically after 
simulation. 

The dialog will graph the turning angles of the various 
trailers as well as the steering angle of the tractor against the 
centerline chainage of the track path. The maximum angles 
as specified in the vehicle dimensions option will also be 
indicated. The graph and array, as well as an alignment 

summary can be printed using the Print button. 

Press Close to close the Results dialog. 
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Minimum Turning Circle Envelope 

Select the Turn ► Minimum Envelope ► Minimum Envelope 

Setup option, or left click on the Minimum Envelope icon on 

the Turn toolbar to display this dialog: 

 

The coordination interval and Simulation type can be set in 
this dialog in the same way as in the main setup dialog.  
When creating a Reverse envelope, the program will 
automatically calculate the optimum coordination interval 

for the curve.   

The turning direction can be set to either left or right.  The 
[Turn through] option can be set to any angle between 0 and 

180 degrees. 

When pressing OK you will be prompted to indicate the start 
point of the envelope, as well as the initial direction of 
movement before turning through the specified angle and 

direction. 

When selecting the Turn ► Minimum Envelope ► Create 

Minimum Envelope option or right click on the Minimum 
Envelope icon on the Turn toolbar, the setup dialog will not 
be displayed and you will be prompted to indicate start point 
and direction as before.  The envelope will be created using 

the previous settings. 
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Absolute minimum envelope 

The program will simulate a turn at low speeds with the 
steering wheels at the maximum angle as specified in the 
vehicle file.  It is assumed that the distance in which the 
steering wheels are turned is neglect ably small, because of 

the low speed at which the vehicle is traveling. 

In a maneuver like this, it is possible (especially with long 
trailers) that the maximum specified angle between tractor 
and trailer might be reached.  When this happens the 
program will automatically calculate a new steering angle in 

order to avoid reaching these maximum angles. 

 

The turning angle graph will look like this: 

 

 

TRH 17 Template 

This method will create a minimum turning envelope in such 
a way that the outer front wheel will travel exactly on a 
circular curve, which means that the vehicle reaches its 

maximum steering angle close to the crest of such a circle. 
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The turning angle graph will look like this: 

 

Around a Kerb 

When running this method, the program will use a specified 
kerb radius and lane width to calculate the minimum turning 
envelope for a vehicle that has to turn around the specified 

kerb. 

The following formulas will be used: 

RIR = RK + (W - w) / 2 + 0.6 

ROF = [ (RIR + W)
2
 + L1

2
 + L2

2
 ]

0.5
 

Where: 

L1 Wheelbase of the Tractor 

L2 Wheelbase of semitrailer 

w Track Width 

W Trough lane width 

RK Kerb Radius 

RIR Inner rear track radius 

ROF Outer front track radius 
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Dynamic Simulation 

Select the Turn ► Minimum Envelope ► Minimum Envelope 

Setup option  

No pre-defined track path is necessary to run a simulation 

using this function.  

Procedure 

The program will prompt: 

Indicate Vehicle start position. 

Graphically Indicate the position where the centre point of 

the vehicle's front axle must be. 

The program will prompt: 

Indicate Vehicle direction of initial movement: 

A rubber-band will be drawn from the start position to the 
cursor position. Use the rubber-band to indicate the vehicle's 
orientation before movement. A vehicle diagram will now be 

drawn at the start of the simulation. 

The Program will prompt: 

Indicate Waypoint 

Click on a point where the vehicle must move to. The vehicle 
will immediately turn its steering wheels toward the 
indicated point and start moving in that direction. When the 
steering wheels reach their maximum steering angle, the 
vehicle will turn at its maximum steering angle, therefore 
turning at its minimum turning radius, until the wheels can 

be turned directly towards the waypoint. 

The program will repeatedly ask for waypoints, running the 

simulation from waypoint to waypoint, until you press Esc.  
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Tutorial 1 – Create a New Vehicle File 

This tutorial will show you haw to create a user defined 
vehicle group file. You will learn how to: 

• Set up a project in Civil Designer / AllyCAD 

• Create a new Vehicle Group file (*.vcl) 

• Add a User defined vehicle to the file. 

 



3-2 Civil Designer Turn 

Set up a project 

A project containing a drawing must be created before the 

Turn functions can be used. 

Select the File ► New Project option in any mode.  Check the 
[Drawing] option and in the File open dialog, specify the 
drawing to be C:\CivDes63\Drawings\TrackTutor.drg and 
press Open to enter the drawing name into the New Project 

dialog. 

 

Press OK and create a new project file with the following 

name:  

C:\CivDes63\Examplas\TrackTutor.cdp 
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Create a new Vehicle File 

Open the Turn Setup dialog by selecting [Turn][Setup] from 
the Design Center menu, or press the Setup button on the 

Turn toolbar. 

 

Press the File Open […] button next to the “Group File 
Name”.  Scroll to the “C:\CivDes63\Examples” directory and 
type the file name “Tutor Vehicles.vcl” into the [File Name] 

edit box. 
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Press [Open] and create a new file. You will then be returned 

to the Setup dialog. 

You just created a new Vehicle group file.  Note that the 

Vehicle combo box in the Setup dialog is empty.  
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Add a user defined vehicle 

We will now add a vehicle to the file.  Press the [Add Vehicle] 
button on the Setup dialog to display the Add Vehicle dialog.  

Specify the new vehicle name and type as follows: 

  

Press OK to create the vehicle and open the Vehicle 

dimension dialog.   

Edit the Vehicle dimensions as follows: 

 

 

Press OK to return to the Setup dialog.  The new vehicle will 
now be added to the Vehicle group file and therefore be 
included in the [Vehicle] combo box.  Make sure that the “23 

m Interlink” is selected.  Press OK to close the Setup dialog. 

In this tutorial we created a Vehicle file called “Tutor 
Vehicles.vcl” which includes a single vehicle called “23 m 

Interlink”.  
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Tutorial 2 – Run a forward simulation 

In this tutorial we will use the vehicle file created in Tutorial 
1 and run a forward simulation. 

You will learn how to: 

• Edit the Turn setup 

• Define the track path 

• Run the simulation 

• Add a Vehicle profile 
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Edit the Turn Setup 

Select the Turn ► Setup option or press the Setup button on 
the Turn toolbar.  Make sure the “TutorVehicles.vcl” file is 

open and the active vehicle is the “23 m Interlink”. 

Change the Coordination Interval and Simulation Type to 

“0.5m” and  “Track Path” respectively. 

Check the Draw Vehicles at control points option to draw a 

vehicle diagram at every control point on your track path. 

Change the rest of the dialog as follows: 

 

We are changing the Layer names because we will be 

running a Reverse simulation in a later exercise. 
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Define the track path 

The track path is already drawn on the TrackTutor.drg 
drawing and is situated on the TURN_CL layer.  There are 
two track paths on the drawing, a forward path (indicated by 
a green arrow) and a reverse path (indicated by a blue 

arrow). 

Select the Turn ► Define Path ► Manual Tracking option from 
the Design Centre menu, or left click on the Define Path 

button on the Turn toolbar. 

 

You will be prompted:  

Select the road centre line one element at a 

time 

Start at the green arrow and click on each track path 

element. Right click to indicate the end of the path. 

The program will now calculate coordinates at 0.5 m 
increments along the specified path.  These coordinates will 

be kept in memory until you run Define Path again. 
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Run the Simulation 

Select the Turn ► Run Simulation option from the Design 
Centre window, or press the Run Simulation icon on the 
Turn toolbar.  The vehicle will move along the track path and 

leave behind the tracks of the vehicle’s wheels. 

The Simulation Results dialog will be displayed auto-

matically. 

 

 

You can use the graph to see exactly at which point any of 
the limiting angles (as specified in the Dimension dialog) 

were exceeded.  Press the Print button to print the results. 
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Your drawing should now look like this. 

 

 

The tracks generated by the simulation are poly-lines.  You 
can therefore select and move them to fit within the curb 

lines. 
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Add a Vehicle Profile 

A Vehicle profile is a drawing similar to that of the Vehicle 

dimension dialog. 

Select the Turn ► Add Profile option or press the Add Profile 

button on the Turn toolbar. 

You will be prompted: 

Indicate position for vehicle profile 

Indicate a suitable position by left clicking on the drawing.  

At the prompt 

Convert Attributes to Text during load 

press YES.  You will now be given the opportunity to move 

and rotate the profile. 

Your drawing should now look like this: 

 

 



Tutorial 3 – Run a reverse simulation 5-1 

Tutorial 3 – Run a Reverse simulation 

In this tutorial we will use the vehicle file created in Tutorial 
1 and run a forward simulation. 

You will learn how to: 

• Edit the Turn setup 

• Define the track path 

• Run the simulation 
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Edit the Turn Setup 

Select the Turn ► Setup option or press the Setup button on 
the Turn toolbar.  Make sure the “TutorVehicles.vcl” file is 

open and the active vehicle is the “23 m Interlink”. 

Change the Coordination Interval and Simulation Type 
settings to “0.5m” and  “Swept Path” respectively.  Change 

the Simulation Direction to “Reverse.” 

Check the Draw Vehicles at control points option to draw a 

vehicle diagram at every control point on your track path. 

Change the rest of the dialog as follows: 

 

We are changing the Layer names because the program 
automatically deletes the specified layers in the [Envelope 

drawing settings] group, before running a new simulation. 
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Define the track path 

The track path is already drawn on the TrackTutor.drg 
drawing and is situated on the TURN_CL layer.  There are 
two track paths on the drawing, a forward path (indicated by 
a green arrow) and a reverse path (indicated by a blue 

arrow). 

Select the Turn ► Define Path ► Manual Tracking option or left 

click on the Define Path button on the Turn toolbar. 

 

 

 

The program will prompt: 

Select the road centre line one element at a 

time 

Start at the blue arrow and click on each track path element 
and right click to indicate the end of the path. 

The program will now calculate coordinates at 0.5 m 
increments along the specified path.  These coordinates will 
be kept in memory until you run Define Path again. 
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Run the Simulation 

Select the Turn ► Run Simulation option or press the Run 
Simulation icon on the Turn toolbar.  The vehicle will move 
along the track path and leave behind the area that the 

vehicle consumed. 

The Simulation Results dialog will be displayed 

automatically. 

 

 

You can use the graph to see exactly at which point any of 
the limiting angles (as specified in the Dimension dialog) 

were exceeded.  Press the Print button to print the results. 
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Your drawing should now look like this. 

 

 

 

The envelope generated by the simulation consists of poly-
lines.  You can therefore select and move the envelope to fit 

within the building lines. 
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Tutorial 4 – Cargo Tracking 

This routine enables you to simulate a vehicle with a cargo 
that extends beyond the body of the vehicle.  The cargo’s 
limits can be specified and will be tracked when running the 

next simulation. 

In this tutorial you will learn how to: 

• Edit the Setup dialog. 

• Specify the cargo limits. 

• Turn the cargo limits. 
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Edit the Setup dialog 

Select the Turn ► Setup option or press the Setup button on 
the Turn toolbar.  Make sure the “TutorVehicles.vcl” file is 

open and the active vehicle is the “23 m Interlink”. 

Check the Apply Cargo point Tracking check box in the 

Drawing Envelope Settings group. 

Specify a pen colour for the Cargo Line. 

Set the Simulation Type to “None” and the Simulation 

Direction to “Forward”. 

 

Cargo tracking can also be done in conjunction with any 

Simulation type (i.e. Track Path, or Swept Path). 
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Specify the cargo limits 

Press the Designer button on the Setup dialog to display the 

Cargo point Tracking dialog.  

A diagram of the active vehicle will be drawn in the view area 
of the dialog.  You can alter the view by magnifying [M], de-

magnifying [D], panning [P], redrawing [R] or refreshing [S]. 

The cargo that we will simulate is situated on the first trailer, 

and extends 1.5 m beyond the front axle of the tractor. 

Check the Trailer 1 radio button in the Cargo Location 

group.  The first trailer will be highlighted in a cyan pen. 

Enter the H-Coord as “1.2”, which indicates that the cargo is 
situated on the right hand side of the trailer. Enter the V-
Coord as “–1.5”, which means that the cargo is situated 1.5 m 

in front of the tractor’s front axle. 

 

You can also indicate the cargo position by using your mouse 
as well as jumping to the nearest point using the “J” key.  A 

blue circle indicates the cargo position. 

Press OK to return to the Setup dialog. 
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Track the cargo limits 

Define the correct track path as in Tutorial 2. 

Select the Turn ► Run Simulation option or press the Run 

Simulation icon on the Turn toolbar. 

 

 

 

The vehicle will move along the track path and leave behind 
a line, which represents the position of the defined cargo 

position along the path. 
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Tutorial 5 – Minimum Turning Circle 

This function enables you to create a minimum turning circle 
envelope.  The vehicle will move in a specified direction and 

then turn at its maximum steering angle. 

In this tutorial you will learn: 

• Edit the  Minimum Turning Circle setup. 

• Create a Minimum Turning Circle envelope. 
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Edit the Minimum Turning Circle Setup. 

Select the Turn ► Minimum Envelope option or left click on the 
Minimum Envelope icon on the Turn toolbar. The Minimum 

Turning Envelope dialog will be displayed. 

 

The Coordination Interval and Simulation Type options are 
exactly the same as in the main Setup dialog. 

The Simulation direction option can be set to either 
“Forward”  or “Single Unit Reverse”.  This means that you 
may create an envelope with the vehicle running forward, 

but it may only reverse if there are no trailers connected to it. 

Refer to the following illustrations for the explanation of the 

Turning Direction and Turn Through options. 
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Press OK to close the Minimum Turning Envelope dialog. 



 

7-4 Civil Designer Turn 

Create a Minimum turning circle Envelope 

The program will prompt: 

Indicate Start point of minimum turning 

circle envelope 

Indicate the position where you want the vehicle to start the 

movement.  

 The program will then prompt 

Indicate direction of initial movement 

A line will be drawn from the indicated starting point to the 
current cursor position. Use this line to indicate the direction 

at which the vehicle must start moving.   

The active vehicle will then move in the indicated direction 
and turn at its maximum steering angle in the specified 

direction, through the specified angle. 

You can select and move the envelope and use it as a 

template.  
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